تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل

توی این مقاله قصد دارم نحوه پیکربندی میکروتیک برای استفاده از L2TP به همراه IPSec برای کاربران تلفن همراه را آموزش دهم.در این مقاله مراحل را با استفاده از کامند و همینطور با استفاده از GUI آموزش خرید vpn خواهم داد.

قبل از هرچیز مطمئن شوید که فایروال میکروتیک به گونه ای تنظیم شده که میتواند ترافیک را از پورت WAN قبول کند.

موقع نوشتن این مطلب من از Mikrotik OS 6.35.4 استفاده کردم.

اضافه کردن IP Pool جدید

شما میتوانید از IP Pool های موجود استفاده کنید، اما فرض من بر این هست که نیاز هست  Pool جدیدی تعریف بشه.

CLI

/ip pool add name=”L2TP-Pool” ranges=10.1.1.1-10.1.1.100

GUI

nrmuwztmq2r9 - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
New IP Pool

تنظیمات L2TP

قبل از انجام تنظیمات L2TP Server باید پروفایل جدیدی برای L2TP تعریف کنیم

CLI

/ppp profile add name=l2tp-profile local-address=L2TP-Pool remote-address=L2TP-Pool use-encryption=required change-tcp-mss=yes dns-server=8.8.8.8

GUI

atqpus70gvr5 - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
PPP Profile

اضافه کردن L2TP Server

CLI

/interface l2tp-server server set authentication=mschap2 default-profile=LT2P-Profile enabled=yes ipsec-secret=MYKEY max-mru=1460 max-mtu=1460 use-ipsec=yes

vrcedwfzcs78 - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
L2TP Server

اضافه کردن PPP Secrets

در واقع همان نام کاربری و رمز عبور کاربران VPN هست

CLI

/ppp secret add name=MYUSER password=MYPASSWORD service=l2tp profile=LT2P-Profile

GUI

mf9p6anzdhmk - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
PPP Secrets

تنظیمات IPSec

در IPSec شما میتونید از تنظیمات پیش فرض (مثل Proposals ) استفاده کنید اما پیشنهاد میکنم تنظیمات جدید خودتون رو اعمال کنید.

۱ – IPSec Proposals

CLI

/ip ipsec proposal add name=L2TP-Proposal auth-algorithms=sha1 enc-algorithms=3des,aes-256-cbc pfs-group=none

GUI

nsag6rwmijvx - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
IPsec Proposals

۲-IPSec Peers

CLI

/ip ipsec peer add address=0.0.0.0/0 port=500 auth-method=pre-shared-key secret=”MYKEY” generate-policy=port-override exchange-mode=main-l2tp send-initial-contact=yes nat-traversal=yes hash-algorithm=sha1 enc-algorithm=3des,aes-256 dh-group=modp1024

GUI

o3gkylfnqju7 - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
IPsec Peers

۳ – IPSec Policies

CLI

/ip ipsec policy add src-address=::/0 dst-address=::/0 protocol=all template=yes group=default action=encrypt level=require ipsec-protocols=esp tunnel=no sa-src-address=0.0.0.0 sa-dst-address=0.0.0.0 proposal=L2TP-Proposal

GUI

s83xi4rkacja - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل
eb1qgawcodwm - تنظیمات L2TP-IPSec میکروتیک برای کاربران موبایل

در پست های بعدی نحوه تنظیمات در سیستم عامل های مختلف را آموزش خواهم داد

منبع : خرید vpn در iransafe.net

Tagged

خرید vpn sstp

پروتکل L2TP چیست ؟

ایرانسیف : پروتکل L2TP ترکیبی است از پروتکل های PPTP و (Layer 2 Forwarding) L2F که توسط شرکت سیسکو توسعه یافته است. این پروتکل ترکیبی است از بهترین خصوصیات موجود در L2F و PPTP.

L2TP نوعی پروتکل شبکه است که فریم های PPP را برای ارسال بر روی شبکه های IP مانند اینترنت و علاوه بر این برای شبکه های مبتنی بر X.25، Frame Relay و یا ATM کپسوله می کند. هنگامی که اینترنت به عنوان زیر ساخت تبادل اطلاعات استفاده می گردد، L2TP می تواند به عنوان پروتکل Tunneling از طریق اینترنت مورد استفاده قرار گیرد

L2TP برای نگهداری تونل از یک سری پیغام های L2TP و نیز از پروتکل UDP (پروتکل تبادل اطلاعات به صورت Connection Less که پس از ارسال اطلاعات منتظر دریافت cknowledgment نمی شود و اطلاعات را، به مقصد رسیده فرض می کند) استفاده می کند. در L2TP نیز فریم های PPP کپسوله شده می توانند همزمان علاوه بر رمزنگاری شدن، فشرده نیز شوند. البته مایکروسافت پروتکل امنیتی Ipsec را به جای رمزنگاری PPP توصیه می کند. ساخت تونل L2TP نیز باید همانند PPTP توسط مکانیسم (PPP EAP، CHAP، MS-CHAP، PAP) بررسی و تایید شود.

نحوه استفاده از سرویس VPN

توجه : برای سهولت کار کاربران مبتدی ، یک Connection از قبل تنظیم شده در بخش دریافت فایل قرار داده شده است. کاربرانی که مایل به ساخت و تنظیم کانکشن VPN نیستند ، میتوانند با دریافت این Connection بدون مشکل و تنها با یک کلیک از سرویس خود استفاده نمایند

پروتکل PPTP چیست ؟

پروتکل Tunneling نقطه به نقطه، بخش توسعه یافته ای از پروتکل PPP است که فریم های پروتکل PPP را به صورت IP برای تبادل آنها از طریق یک شبکه IP مانند اینترنت توسط یک سرایند، کپسوله می کند. این پروتکل می تواند در شبکه های خصوصی از نوع LAN-to-LAN نیز استفاده گردد.

پروتکل PPTP به وسیله انجمنی از شرکت های مایکروسافت، Ascend Communications، ۳com، ESI و US Robotics ساخته شد. خرید vpn یک ارتباط TCPرا (که یک ارتباط Connection Oriented بوده و پس از ارسال پکت منتظرAcknowledgment آن می ماند) برای نگهداری تونل و فریم های PPP کپسوله شده توسط (Generic Routing Encapsulation) GRE که به معنی کپسوله کردن مسیریابی عمومی است، برای Tunneling کردن اطلاعات استفاده می کند. ضمنا اطلاعات کپسوله شده PPP قابلیت رمز نگاری و فشرده شدن را نیز دارا هستند، تونل های PPTP باید به وسیله مکانیسم گواهی همان پروتکل PPP که شامل (EAP، CHAP، MS-CHAP، PAP) می شوند، گواهی شوند. در ویندوز ۲۰۰۰ رمزنگاری پروتکل PPP فقط زمانی استفاده می گردد که پروتکل احراز هویت یکی از پروتکل های EAP، TLS و یا MS-CHAP باشد. باید توجه شود که رمز نگاری PPP، محرمانگی اطلاعات را فقط بین دو نقطه نهایی یک تونل تامین می کند و در صورتی که به امنیت بیشتری نیاز باشد، باید از پروتکل Ipsec استفاده شود

تفاوت پروتکل های PPTP و L2TP چست ؟

هر دو پروتکل PPTP و L2TP از پروتکل PPP برای ارتباطات WAN استفاده می کنند تا نوعی اطلاعات ابتدایی برای دیتا را فراهم کنند و سپس یک سرایند اضافه برای انتقال اطلاعات از طریق یک شبکه انتقالی به پکت الحاق بنمایند. هر چند این دو پروتکل در برخی موارد نیز با هم تفاوت دارند. برخی از این تفاوت ها عبارتند از:

۱) شبکه انتقال که PPTP احتیاج دارد، باید یک شبکه IP باشد. ولی خرید L2TP  برای ios فقط به یک تونل احتیاج دارد تا بتواند ارتباط Point-to-Point را برقرار کند. حال این تونل می تواند بر روی یک شبکه IP باشد و یا بر روی شبکه های دیگر مانند Frame Relay، X.25 و یا ATM.

۲) L2TP قابلیت فشرده سازی سرایند را داراست. هنگامی که فشرده سازی سرایند انجام می گیرد، L2TP با حجم ۴ بایت عمل می کند، در حالی که PPTP با حجم ۶ بایت عمل می نماید.

۳) L2TP متد احراز هویت را تامین می کند، در حالی که PPTP این گونه عمل نمی کند، هر چند وقتی که PPTP یا L2TP از طریق پروتکل امنیتی Ipsec اجرا می شوند، هر دو، متد احراز هویت را تامین می نمایند.

۴) PPTP رمزنگاری مربوط به PPP را استفاده می کند، ولی L2TP از پروتکل Ipsec برای رمزنگاری استفاده می نماید

خرید vpn در iransafe.net

 

خرید vpn pptp

شبکه خصوصی مجازی یا همان خرید vpn به کمک رمزگذاری روی داده‌ها، درون اینترنت یک شبکه کوچک می‌سازد و تنها کسانی که آدرس‌های لازم و گذر واژه را در اختیار داشته باشد می‌توانند به این شبکه وارد شوند.

شرکت پویا پردازش ایران با بر قراری ارتباط نقطه به نقطه (point to point) که به آن در شبکه tunnel یا vpn نیز گفته می شود ،بر روی بستر اینترنت یا اینترانت ارتباط نقاطی که مشتری نیازمند آن است را برقرار می نمایید . در این ارتباط شبکه های داخلی مدنظر به صورت کاملا امن با یک دیگر ارتباط برقرار می کنند

 

خرید vpn - خرید vpn pptp

 

 

خرید vpn خرید vpn آِیفون خرید vpn آندروید خرید کریو خرید pptp vpn خرید vpn پرسرعت

خرید vpn آیفون , خرید vpn آندروید , خرید vpn , خرید فیلترشکن 

hi speed vpn - خرید vpn pptp

خرید vpn , خرید vpn آِیفون ، خرید vpn آندروید ، خرید کریو

شبکه خصوصی مجازی (Virtual Network)